Getting started

From Fractracer Wiki

Jump to: navigation, search

Fractracer uses ".fts" file extension for scripts.

Usually, fts file contains:

  • description of objects
  • visualization parameters (cameras, light sources, and so on)
  • windows layout
  • animation parameters (optional)

To open existing script, use main menu: "File"->"Open". Also you can use any provided sample using the "File"->"Open Example".

To start interactive session and rendering, use "Rendering"->"Run" from main menu. To stop session, use "Rendering"->"Stop".

Usually, when script is started, you should see Objects and Parameters dialogs. You can close any dialog or move it to another position. Any closed dialog, can be opened from main menu: "View->Dialog Name".

To save rendered image or 3d mesh, use main menu: "File"->Save Picture/Mesh"

Program settings available from "Options" dialog: "Tools"->"Options"

You cannot change running script using built-in editor. When you stop session, all changes (parameters in dialogs, windows layout and so on) will be saved back into the script.

To save changes in the script, use "File"->"Save" from main menu.

Personal tools